There is a problem with Internet Explorer and the MOT testing service
Incident Report for MOT Service Status
Resolved
This incident has been resolved.
Posted May 12, 2022 - 08:03 BST
Identified
The issue has been identified and a fix is being worked on.
Posted May 10, 2022 - 11:07 BST
Update
We are continuing to investigate this issue.
Posted May 06, 2022 - 10:00 BST
Investigating
We have identified a problem with Internet Explorer and the MOT testing service.

In some cases when using Internet Explorer the mileage can’t be recorded during test result entry.

To resolve the problem you will need to sign out and sign back in on a different web browser, for example, Chrome, Edge, Safari or Firefox.
Posted May 05, 2022 - 10:42 BST
This incident affected: MOT testing service.